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Chapter 7  Overview of Editing Concepts
NASIS offers several software tools and features for editing your data. This lesson
covers some of the basic editing functions that are available in each of the major areas of
NASIS.

Copying and Pasting Data
The Copy command places a duplicate of the selected object(s), including all associated
records, onto the clipboard. The Copy Rows command places a duplicate of the selected
rows, with none of the associated data, onto the clipboard. No changes are made to
original data when you copy it. For that reason, you can copy any data, including data
you do not own or data that is locked.

The Paste command transfers the data that has been placed onto the clipboard into the
selected table.

Copying a row
1. On the File menu, click Select.
2. Choose the Tutorial - Sites, pedons query.
3. Highlight only the Site table, then click Apply.
4. Enter an asterisk "*" in the Site User ID field, then click Apply.

Note: A message will inform you that 2 rows were added to the Site table.
5. Click OK, then Cancel the Select Manager.
6. On the View menu, click Sites, then click Site.
7. Position your cursor on the row containing Rec ID 3, then click Down table.
8. Highlight the 4/28/1996 observation date on the Site Observation table.

Note: In a later lesson you will spend time examining these tables. This lesson
focuses on copying data rather than on the detail of these tables.
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9. Click Edit, then Copy Rows.

Note: The contents of the row have been copied to the clipboard.
10. Click Paste. A new row appears marked with an N indicating that it is new.

Copy rows



Chapter 7:  OVERVIEW OF EDITING CONCEPTS

(430-739, Version 5.0, Feb. 2001)     7.3

11. Position your cursor in the new row, then click Down table.

Note: The Site Soil Moisture table is empty, no associated data was copied.
12. Click Up table.
13. With your cursor still positioned in the new row, click Cut.

Note: The row is now marked with a D meaning Deleted.  You will now be able to
do another copy without confusing the two new rows with each other.

Copying a row and its associated data
1. Position your cursor on the original row with 4/28/1996 observation date. Click the

Copy button this time.
Note:  This time the row and its associated data have been copied to the clipboard.
When you copy data to the clipboard, it remains there until you replace it by copying
something else or exit NASIS.
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2. Click Paste.
3. Position your cursor in the new row, then click Down Table.

Note: The Site Soil Moisture table contains associated data.

Performing Global Edits
Global editing is a powerful capability in NASIS. It lets you change large amounts of
data quickly and easily.

This powerful tool can save you time, but it also presents the risk of damaging large
amounts of existing data if your selected set includes records that you don't want to
overwrite. For this reason, it is essential that you understand the concepts of objects, the
selected set, and target tables.

Performing a global paste

First, you will globally paste the data already on the clipboard into multiple locations. A
global paste operation can only be performed from a parent table.  A parent table is one
that can have one or more subtables, or child tables.  In the example above, the
Observation table is a child of the Site table.  The following example will show a copy
from the parent, or Site table.

1. Click Up table twice. Your cursor should now be positioned in the Site table.
2. Position your cursor in the row containing Rec ID 13.
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3. Click Paste.  The Paste Options dialog will be displayed.

Note:  The default selections for a global paste limit the paste to the row selected
and prevent you from unintentionally overwriting any existing site observations.

4. Click Paste Site Observations to All Sites(s).
5. Click Apply, then Down table.

Note: You performed the paste at the Site table level, the Site Observation table for

Specifies data to
be copied and
destination table
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all site observation records in your selected set now contains the new record for the
4/28/1996 date.

 Because you chose to Keep Existing Site Observations, the 4/28/1998 record (or
any other site observation records that might have been in the selected set) still
remains in the Site Observation table. Had you chosen Delete Existing Site
Observations, the Site Observation table would no longer contain the observation
for 4/28/1998.

 Note: Record ID 3 contains the Observation Date 4/28/96 three times, the original,
the new row, and the copied row. Working with real data, you would edit each
record to make it unique after adding or copying a row. In the tutorial database
redundant data will not create a problem, because you are not allowed to save data.

Understanding Global Assign
Global assign differs from the paste option in that Paste works on the entire row, while
Global Assign works on an individual column. With the Global Assign command, you
can globally edit specific data element values, such as changing a horizon designation
from H3 to Cd for the same components in all data mapunits, or changing the T value for
a group of selected soils. Global Assign allows you to assign a single value to an entire
selected set of data.

If someone else owns some of the data mapunits in your selected set when you do a
Global Assign, NASIS will only perform the operation on the records you have
permission to change. It will ignore the unowned records. If some of the records in your
selected set are locked, that is, someone else loaded them into their selected set before
you did; NASIS will not even attempt the global editing operation. You will receive a
message indicating that at least one record is locked and the global operation fails.

If after performing a global edit you realize you inadvertently changed records and need
to reverse the action, you have three options: Clear the selected set (File menu, New)
without saving to the permanent database; exit NASIS without saving, or use the De-
select command to remove those records you inadvertently changed. A later lesson
provides hands-on experience with the Global Assign command.

Overview of Global Delete and Global Un-Delete
The Global Delete command gives you the capability of deleting large amounts of data
in your selected set. It works on the current table, that is, the table that contains the
highlighted cursor.

For example, in a later lesson, you will build a selected set of all the data mapunits in the
tutorial database containing a component that is less than three percent. Only the
components that are less than 3% will be loaded for each of the data mapunits, even
though the data mapunits may have many other components.

In NASIS, if your cursor is in a root table, you can easily highlight all records and use
the Delete command to delete them. However, if the cursor is in a child table, for
example, Component table, you cannot highlight all components in the selected set; you
can only highlight all components in the currently selected data mapunit. Global delete
allows you to bypass this limitation. For child tables, you can use the Global Delete
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command to delete all components of all data mapunits in the selected set. Global delete
and un-delete are discussed in a later chapter, after you have had an opportunity to
familiarize yourself with the data.

Examining a Custom Edit Setup
Many of the tables in NASIS contain more columns than you can view on the screen at
the same time. Scroll bars allow you to move both vertically and horizontally. On
screens with numerous columns, such as the Component screen, editing may involve
scrolling between columns several times for each row that you edit. Edit setup allows
you to customize the way tables display in NASIS. One or more columns can be hidden
from view. Additionally, you can change the order in which the columns display. You
can also choose to "lock" some columns in the viewing area. Locked columns remain
visible while remaining columns to their right scroll when using the horizontal scroll bar.

Selecting a custom edit setup

The following exercise demonstrates changing the view of the component table to
simplify editing the CEC horizons on multiple rows.

1. Clear the selected set by selecting the File menu and choosing New. The New
function clears the entire selected set and starts a new one. Click OK.

2. On the File menu, click Select.
3. On the Select Manager, select the Tutorial - Component name query.
4. Highlight the Component target table, then click Apply.
5. Enter OCCUM in the component name, then click Apply.

Note: The Component Name is case-sensitive.

If this
message
appears,
click OK.
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Note: A message is displayed indicating 14 rows were added to the Component
table.

6. Click OK, then Cancel to exit the Select Manager.
7. On the View menu, select Data Mapunits, Data Mapunit.
8. Highlight the row containing DMU ID 134, click Down table. The OCCUM

component is displayed.
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9. Click Down table to display the Horizon table.

10. Using the scroll bar below the Horizon table, scroll to the right until the CEC-7
fields are displayed.

11. Now, click the Up arrow on DMU table once to change to DMU ID 106.

Note:  The arrow location on the DMU table is indicated in the above graphic.

Arrows on
table allow
you to switch
data mapunits
and
associated
component,
horizon
information.
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Note: The horizon table now displays the OCCUM components and horizons for
DMU ID 106. If you needed to add CEC-7 values to several B horizons in OCCUM
components, it would be difficult to know whether the visible horizons included B
horizons. All horizon identification has scrolled off the left side of the screen. If you
needed to enter different values in several of the OCCUM component horizons, this
could entail repeatedly moving the scroll bar. A custom edit setup eliminates this
problem.

12. On the Options menu, select Change Edit Setup.

13. Click the Help button on the dialog for detailed information about the Edit Setup
Manager.

Width of scroll bar is proportionate to
the percentage of columns visible
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14. After viewing the help, highlight CEC Update in the select list, then click Apply.
Note: Observe the changes in the edit setup table. The first column now displayed is
the Designation column. Some columns are now hidden, others are frozen (do not
scroll).

15. Click the down arrow on the Data Mapunit table to return to DMU 134. The
Designation information on the horizon table remains clearly displayed.

16. Move your cursor to the scroll bar below the Horizon table. Move the scroll bar to
the right.

Frozen columns Scrollable columns

Arrows on the
table allow
you to switch
data mapunits
and
associated
component
and horizon
information
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Note: The Designation, Top Depth, and Bottom Depth columns remain fixed on the
screen while the other columns scroll. Those columns are frozen in the CEC Update
setup. Also, the scroll bar displays much wider than it did in the Default setup. The
width of the scroll bar indicates how much of the viewable data is currently
displayed on the screen. Only 13 of the 183 columns in the Horizon table are
viewable with the CEC Update setup.

Restoring the default edit setup

NASIS provides a default setup that you can use to restore all tables to their original
setup.

1. Position your cursor in the CEC-7 Low column for any row.
2. Return to the Options menu and click Change Edit Setup.
3. Click National on the Edit Setup Manager.
4. Highlight Default on the select list.

5. Click Apply.
6. Observe the Horizon table. The CEC-7 information is no longer visible, because the

cursor has returned to the beginning of the row.

Creating a Custom Edit Setup
1. On the File menu, select New.
2. On the View menu, click Plants, then click Plant Area Occurrence.
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3. Use the slider bar at the bottom of the Plant Area Occurrence table to view the
columns.  You are going to create an edit setup that reduces the number of columns
displayed on this table and formats displays of the remaining columns.

4. On the NASIS View menu, select Edit Setups, then Edit Setup, and press F8 to
open a new row.
Note: If the F8 key does not work, check three things: Make sure the object status
reads “unchanged” (which means it is editable), make sure the CAPS LOCK key is off,
and make sure the NUM LOCK key is off.

5. Enter Test Setup in the Edit Setup name.
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6. In the Description column, highlight Text ..., then press the Zoom button.
7. Enter a description of the edit setup in the text field editor.
8. Press Apply to return to the Edit Setup table.
9. In the Edit Setup column, highlight Edit Setup... in the new row, then press the

Zoom button.

Note: The Setup Editor will appear. The righthand section of the Editor lists the
objects in NASIS. Each object contains a group of tables. If a table does not appear
in the list, a custom edit setup cannot be created for it. Column information will not
be listed until a table is chosen.

10. Click the Help button on the dialog for detailed information about the NASIS Setup
Editor.

11. After viewing the help topic, select the Plants object by double-clicking the folder.
A list of tables is displayed below the folder listing the tables in the group.

12. Click the Plant Area Occurrence table icon to select a table from the folder. When
a table is selected, information for each of the columns in the table will display on
the lefthand side of the NASIS Setup Editor.
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Note: The background of the table icon changes color when a table is selected for
modification.
Note: The Plant Area Occurrence table only has a few columns. Typically, you
would not bother to create an edit setup for such a small table. However, working
with a small number of columns allows you to view the results of your edits more
easily in this example.

13. In the columm labeled Display Column, click the checkbox for the Seq and Rec ID
rows. All columns display by default, you have just de-selected the two columns so
that they will not display on the Plant Occurrence table when the setup you are
creating is applied.
Note: If a table has numerous columns and you only wish to display a few, you will
find it quicker to click Hide All. Hide All de-selects all columns. Then, you can
click individual columns to include only those you want. They will display in the
order in which you select them, unless you change the order using the position
arrows/field.

14. In the Position column, use the arrows or type in a number to increase or decrease
position number and adjust the display order as shown in the screen on the next
page.
Note: Display position determines sequence (left to right) in which columns display
on the screen. This is significant, if you wish to freeze some columns in place while
allowing others to scroll. A position number of 0 is listed for columns that you
choose not to display. Position number cannot be higher than the number of columns
displayed.

15. Specify field width by typing the width values shown on the sample screen.
Note: Reducing field width may cause some data to appear truncated.

16. Type or use the arrow keys to specify the sort order shown.
17. Indicate columns that should sort in ascending order shown.

Note: You may sort data using columns that do not display on the screen.
18. Enter 1 in the Frozen Columns field.

Note: Columns numbered up to and including the specified number will stay locked
in position onscreen. Columns to the right of locked columns will scroll horizontally,
if the screen is not wide enough to display all columns at the same time.
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Note: Your completed edit setup form should appear as above.
19. Click Apply.
20. On the Options menu, select Change Edit Setup.

21. Select Test Setup.
22. Click Apply to activate the new setup.
23. On the View menu, click Plants, then click Plant Area Occurrence. This time the

leftmost column is the Area Symbol.
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24. Use the slider bar to scroll to the right. Observe how the Area Symbol column
remains fixed while the Area Type Name slides out of sight.

Area Symbol now
leftmost column

Area Type Name column scrolls
while Area Symbol column
remains locked
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Lesson Summary
In this chapter, you performed basic editing tasks that you can apply throughout NASIS.
You copied both row and object data, pasted data to individual rows, pasted data
globally to all related rows in your selected set, and compared the copy and paste
functions to the global assign, delete, and un-delete functions.

Additionally, you examined how an edit setup changes the display properties of a table.
You also went through the process of editing a table setup and applying your new setup
to a table display.

These editing functions can be used to manage data in any of the objects and tables in
NASIS. In the next lesson, you will find out how to export NASIS data to other
applications.


